Original Post — Direct link

Hello all

I come here as a last re sort I’ve checked everything I could online and have tried everything I could think of.

re loaded old saves and got to level 4 with the rebels again so I could buy all the gear. Tried reloading games fast travelling to England and back. Changing out gear and re equipping what’s needed for achievement, restarting Xbox tried every combo of scythes. Made sure I had nothing in my off hand or bow did it with an item in my offhand and a bow. Killed an enemy with two scythes equipped. Tried every kind of enemy. I’ve done everything I listed multiple times. I got 200 hours in this game and this is the last thing I need pretty much to 100% this game. So of course the most random bug would stop me with an hour of game play left. Any help would be very appreciated.

about 1 month ago - Ubi-Mark. - Direct link

Hello @deon_the_great,

Sorry to hear that your achievement hasn't been unlocked.

Can you please provide us with a short video of this occurrence showing the actions performed, your map, completed quests, and your achievement locked, so we can investigate it further for you?

Many thanks and if you have any additional questions, please let us know.






Recent Assassin's Creed: Valhalla Posts

about 2 hours ago - Ubi-Froggard