about 2 months ago - AndrewT - Direct link
Of those games you list, only EU4 uses the new launcher.

Please try this:

- uninstall Paradox Launcher v2 from the Windows "Apps and features" utility, if still present.

Delete the following folders if still present:

- C:/users//AppData/Local/Programs/Paradox Interactive/
- C:/users//AppData/Local/Paradox Interactive/
- C:/users//AppData/Roaming/Paradox Interactive/launcher-v2/
To see the AppData folder you'll need to enable View Hidden Items in File Explorer.

- exit the Steam app entirely
- run steam.exe as the Windows Admin user

- run the game from the PLAY button in Steam

IF that doesn't help, in this folder are some .log files:
C:/users//AppData/Local/Paradox Interactive/launcher-v2/
Please attach them here.  
about 2 months ago - AndrewT - Direct link
The 1603/1605 errors we see there are typically a previous other installation stuck, or a problem in the Windows update/install processes.

If you see msiexec running in Task manager-processes, kill it and try this launcher install again please.

Otherwise run the Update app in Windows, does it load okay, find anything to apply - whether a patch, update, or whole new Windows 10 version? If so do that and reboot, then try this launcher install again please.

If still no good, do you see Paradox Launcher v2 in the Windows Control Panel to uninstall? If so does it uninstall cleanly, or get an error doing that? Use this MS tool to remove that stuck in stall/uninstall:

Fix problems that block programs from being installed or removed

The Program Install and Uninstall troubleshooter helps you automatically repair issues when you're blocked from installing or removing programs. support.microsoft.com support.microsoft.com  
about 2 months ago - AndrewT - Direct link
Carreter Solitaria said: View attachment 867012
Hello, I also faced the same problem. I rummaged through all the forums, as the launcher refused to work, as a result, I could hardly remove it, and instead of the old error, a new one appeared, associated with drive F, which is currently under repair and is not on the computer. Can you advise on this problem?
Did you use the MS tool I linked? It should fix this.  
about 2 months ago - AndrewT - Direct link
Carreter Solitaria said: Yes, I have used it. He helped with the removal of the program, but does not detect it in the downloads
Well, with that and deleting the folders I listed, the installer ought not to be referencing F: any more. You sure you did all that?  
about 2 months ago - AndrewT - Direct link
Oh, was your Windows User Documents folder held on F: ? If so you have to re-point it to somewhere that actually exists, such as the default C:/users//Documents/ folder.  
about 2 months ago - AndrewT - Direct link
That screenshot shows your program files location, not your Windows User Documents location.

In any case there are still 1603/5 errors in that log, so we're still at the position I outlined in post #4 above - there's a stuck install/uninstall there. If that MS tool cannot find or fix it, you can try the two free utilities Ccleaner and Revo Uninstaller.  
about 1 month ago - AndrewT - Direct link
LordWillo said: Dear both,

I tried all the solutions listed above and nothing happened.
Plus yesterday i bought HOI4 and some dlcs, I'm able to play it skipping the launcher because if I try to open the launcher the "Invalid drive" message pop up.
Did you use the MS tool I linked? It should fix this.