12 days ago - UbiViral - Direct link
Originally posted by Get_better_nerd: when i try to load in the game it says "there was a problem authenticating the ownership of the product" just got the game and wasted 20 something dollars and it doesn't even work.
I have tried customer support still doesn't work.

Hey! Sorry to hear that you are getting this error message.

This error usually occurs when you are using an account the game was not originally activated on.

In order to investigate this further, please provide the following as full screenshots on a support case here: https://support.ubisoft.com/en-US/Cases/New

- Proof of purchase: https://support.ubisoft.com/en-GB/Article/000061770

- Steam ID or Steam username: https://support.ubisoft.com/en-GB/Article/000060565

A full screenshot from the following folder:

C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\ownership

This folder stores Uplay IDs of all accounts that have been logged to on this PC, this is quite useful for our investigation.

Thank you.

- Ubisoft Support





Recent Rainbow Six Siege Posts

about 6 hours ago - Ubi-TheBerry
about 6 hours ago - Ubi-TheBerry