9 months ago - CO_Avanya - Direct link
HealkitMod
This is a really old mod, one of the first compatibility mods. It's long outdated and should be unsubscribed. Skyve is the up-to-date mod for compatibility checks.

I recommend you check all your mods against both the first tab and especially the tab named Patch 1.17.0 of this spreadsheet and unsubscribe the broken mods you may have:
https://pdxint.at/BrokenModCS





Recent Cities: Skylines Posts

9 months ago - CO_Avanya