21 days ago - Taelyn - Direct link
Hi Galactic Survivalists!

We made some changes regarding EAC. This will mean the following for you:

- If you play Alpha 10, Alpha 11, Alpha 12 or the latest V1.4.x and you use EAC then you have to update your game.
If you dont do this you will get EAC errors​

- All previous versions Alpha 9 and below can no longer make use of EAC.
If you play SP or CooP this doesnt matters much as you dont need EAC and for CooP you cant use EAC.
If you use this on a Server we highly recommend that you use a password and only let in trusted people as you cant use EAC anymore on those versions.​

Thank you for the understanding.

Taelyn
Eleon Game Studios





Recent Empyrion: Galactic Survival Posts

21 days ago - Taelyn
about 1 month ago - Pantera
about 1 month ago - Pantera
about 1 month ago - Pantera

devtrackers.gg