Original Post — Direct link

I've been trying to get from Heoborea to Deep Harbor to continue the campaign for an hour and a half. 10% of the time I can't even load into The End of Time, as it gets stuck on the very first load screen. 90% of the time I can take the portal to Heoborea, but it hangs on the loading screen forever. I'll still hear the sounds of opening my inventory or the crafting window, and I can pull up the settings or game menu. Very, very occassionally it will let me load into Heoborea, and only once have I been able to get into Northern Stream, but the same infinite loading screen happened again when trying to exit into Deep Harbor.

I've tried everything I know to try: graphics driver is up to date. Files have been verified in Steam. I've restarted my computer. I've reinstalled the game. Nothing helps.

This is extremely common when trying to enter a timeline boss after first logging in, but I've always just worked around it by doing a mono first and then going to the boss. For this though - the campaign - I can't find a workaround. I've tried loading into other zones first, and it doesn't help. I am beyond frustrated right now, and I've spent 90 minutes trying to do 3 minutes of playtime. I'll spare you from the rest of the rant I have in my head.

Has anyone else dealt with this in the campaign? I would really appreciate tips, if anyone has them.

External link →
4 months ago - /u/moxjet200 - Direct link

There was an issue with a specific server region unrelated to the patch around this time. Can anyone that was experiencing this let me know if you’re seeing the issue resolved? We’re no longer seeing those errors on our end

4 months ago - /u/moxjet200 - Direct link

Originally posted by jarnvidr

Just now getting a chance to log back in. I was able to run all the way to Deep Harbor without any issues this time, and load times seem much faster as well! Seems like whatever the fix is, it worked!

Glad to hear it and thank you for checking! Much appreciated

Other sites