Original Post — Direct link

I'm replaying Ac Valhalla and after 84 hrs it start to freeze every time it autosave bust just for the time the autosave lasts then continue and a few times it get stuck in the autosave symbol and crash. Another thing it start together is every time i enter the map or inventory the screen stay black for about 20 seconds with the loading symbol same for fast travel when arrive to place you hear the voices bur the screen is black and the loading symbol.

I did all the ubisoft troubleshooting
Verify and Repair files
Used a different loading (works for few hours and the same start happen)

I7-6700k @ 4.5mhz
32gb Ram corsair vengeance
MSI RTX 2060 Gaming Z
Corsair RM 650
Windows 10
512 ssd O.S
2 Tb hdd for games
Locked at 60 fps my GPU teps are 59-63 (i live in a very humid area)

13 days ago - Ubi-Keo - Direct link

Hi @carlos8lv I'm sorry to hear that you experiencing micro stuttering whilst the game auto saves.

I can confirm that this issue has been reported previously and is still being investigated.

With regards to the black screen issue that you are experiencing when accessing the map, inventory screen or fast travelling, this is not an issue that I am aware of. Can you confirm how long you have been experiencing this issue? Was it only since installing the latest update, 1.6.0?

Could you please try creating a new manual save, exit the game and then load the newly created manual save and confirm if the issue persists? If it does could you provide a video that demonstrates this issue. In the video we would need to see the following:

  • That you have the latest update installed. This can be seen in the main menu screen before loading your save.
  • Your list of saves to see how many you currently have.
  • The black screen when accessing the map
  • The black screen when accessing the inventory
  • The black screen when fast travelling


I would recommend uploading your video to a video sharing platform such as YouTube, you can then copy the URL link into this thread. 

Can you also ensure that your latest save is uploaded to the cloud. If you are unsure how to do this there is a support article that you can check here

We would also require a copy of your system files. If you could also upload those to a file sharing platform and copy the URL link into this thread.