Original Post — Direct link


So basically, the game just turns off w/o any error code or anything, while I'm in the main menu, which says press any button I can be there for hours! However, when I press anything on my keyboard, game says "Checking for Add-Ons" and then turns off. I tried multiple times I'v even re-downloaded the game (again 150 gigs fss) and still the same problem, I've updated my drivers, everything. I'm just in a blank spot.

Please, help me!!!

2 months ago - Ubi-Massilia - Direct link

Hello @Quirbis

Sorry to hear that you're experiencing crashes because of the "checking add-ons" error when trying to launch Assassin's Creed Valhalla.

After thorough investigation, the development team were unable to reproduce this issue on the live version of the game.

Could you please send us a video of the issue ? So that we can investigate further more on this issue.

In the meantime, if you have any other questions, feel free to ask and we will do our best to help you ! 

Other sites