Original Post — Direct link

My AC Valhalla is refusing to autosave. I have tried workarounds such as rebooting and pressing "continue" and using the bed/feasts however my game is persistently refusing to autosave. My manual saves are also corrupted.

I have successfully verified the game files and no issues were found

I have also tried starting a new game however it still fails to autosave

about 1 year ago - Ubi-SleepyGoat - Direct link

Hi there @Antaris98 very sorry to hear you're having some trouble with your auto-saves and manual saves.

There's a few things that can cause this issue, so I will provide a few articles to guide you through some fixes.

First, if Ubisoft Connect does not have administrator rights, it can prevent saves from being made properly. Start by Reinstalling It by following these instructions.

After that, you will need to make sure Ubisoft Connect is always running with Administrator Rights.

Finally, Ubisoft Connect and the game files need to both be installed onto the same hard drive, if you have multiple drives in your computer. If you do, please make sure that both are on the same hard drive as your Windows installation if possible.

Let me know if you keep having trouble with your saves after this. If you are seeing a specific error message in-game when the game attempts to make an autosave please take a screenshot of that as well.

Other sites