about 2 months ago - SLG-Dennis - Direct link
We do not officially support Mac, there is early developer builds for the 'older' Macs available, but the new M1 Macs are incompatible with the game and hence also won't have any builds soon.





Recent Eco Posts

about 7 hours ago - /u/SLG-Dennis