Original Post — Direct link

I have the standard Xbox Series X controller and cannot get it to work--only on Elite Dangerous. I want the default Xbox bindings, but they do not seem to appear. My options for bindings are shown in the picture attached.

https://preview.redd.it/ylb1w6hgwjr71.png?width=1578&format=png&auto=webp&s=b108ff55371d4d6f732f9a81c39708b62c7927e2

The closest option is Generic Joystick, but this is definitely not the default Xbox controller bindings. When I click a control function to remap it and move the stick it says "[JOY X-AXIS]". This controller works flawlessly for every other game I have ever tried it on. It is connected via bluetooth. I run ED via Epic Games. How can I get default Xbox controller bindings?

External link →

Hi there, please try the following steps:

Open Device Manager

Right Click "Xbox One Controller"

Select Update Driver Software

Browse

Let me pick

"Microsoft Xbox One Controller"

If this doesn't help, please get in touch at https://customersupport.frontier.co.uk/hc/en-us and we can investigate further for you.

- Vostok






Recent Elite: Dangerous Posts