Original Post — Direct link

Y'all I'm so lost, this has never happened to me before. I'm not even sure how I got the bounty but I have a bounty in my home system (Ehecatl) for the EG UNION (their union) I can not pay a fine, pay the bounty, or turn myself in. It says “no bounties found”. I tried going to an interstellar contact and paid off a different bounty but this one doesn't show up. I went to THREE different interstellar contacts and none of them had it listed. I'm about to cry because Im stuck in a crappy ship that can only jump like 10 ly before a refuel is needed. I can't access my other ships cause my home port is anonymous access. I have 0 notoriety. I even tried going to a broker (???????) and nothin*. The game isn't playable like this please help

External link →
over 2 years ago - /u/frontier_support - Direct link


Do send us a support ticket via: https://customersupport.frontier.co.uk/hc/en-us/requests/new and we will be able to help.

- Ikaros

Recent Elite: Dangerous Posts