Original Post — Direct link
Hi All!
I bought For Honor about 6 months ago and tried to run it on my iMac Pro using boot camp. That didnt work.

So I figured i needed to upgrade:
I now have a brand new PC with the following specs:
Ryzen 9 3900X
GEFORCE 3080 FE
MSI Tomahawk 570X
Sabrent Rocet PCIe 4.0 2TB M.2 (It starts Win10 in about 2.5 seconds)
Corsair Vengeance 32GB

It honestly runs like a beast. I can play anything in Ultra settings. GF got me Anno 1800 for Xmas so I did an install and of course when I logged into my account using the Ubisoft game launcher, there was For Honor! Never been used.

I downloaded it and installed it. Today when I tried to run it, it does the little startup screen with the 3 characters, it pops up the epilepsy warning page (windowed) and then crashes, generating a report asking if i want to submit. Which I have done.

So I googled a bit and followed the launch arguments thread in support and changed each of the start commands as it suggests. Nope, still crashing!

No idea what to do next. Its a clean build, all brand new stuff and runs everything else i have loaded faultlessly.

Help please!
23 days ago - Ubi-Litten - Direct link
Hi there, sorry you are experiencing this issue while launching your game. So we can look to getting this resolved could we first ask that you have attempted our basic troubleshooting steps as outlined here.

If you are still receiving this error after completing these steps, could you please provide your system reports as advised in the FAQ guides below :

Generating a DirectX Diagnostic Report

Generating a Microsoft System Information Report

Apologies for any confusion or inconvenience this may have caused.





Links in this thread

Generating a Microsoft System Information report
How can I generate an MSInfo report for my system?


Generating a DirectX Diagnostic report
How can I generate a DxDiag report for my system?


Troubleshooting technical issues on PC
What can I do if I experience technical difficulties while playing on PC?


devtrackers.gg