Original Post — Direct link

Can't play with my friend in group. I send an invitation to the group, but my friend does not receive it. I also don't receive an invitation. The invitation via UbisoftConnect does not work either. I also can't create a group through Ubisoft connect. When I create it, it sends me back to the name of the group. The join button in UbisoftConnect doesn't work either. It says "you will be able to join when a session is available". My NAT is green, my friend's NAT is yellow. I searched the whole internet and didn't find a solution. This problem appeared back in 2019, and today my friend and I faced it. I hope the next update will fix this bug, but if someone knows how to solve this problem, please help!

about 2 months ago - Ubi-Keo - Direct link

Hi @adept05 and welcome to the forum.

I'm sorry to hear that you are experiencing issues playing For Honor with your friend.

Can you confirm which version of Windows you and your friend are using.

about 2 months ago - Ubi-Keo - Direct link

@adept05 Thanks for confirming which version of Windows you and your friend are using.

Can you please check the support article here.

about 2 months ago - Ubi-Keo - Direct link

@adept05 I'm sorry to hear that the issue persists.

I'm afraid there is no further troubleshooting I can provide if those steps do not work.

As you may know support for Windows 7 ended in January 2020 and no further updates are released, therefore the only other thing that I can recommend would be to upgrade your operating system to Windows 10.

Apologies for the inconvenience caused.