18 days ago - /u/thearcan - Direct link

Hi everyone,

As you know we were hoping to release our latest patch today. We have, however, made the difficult decision to push the patch back to Thursday. We’ve explained this decision below – please do take the time to read it as it contains important information.

tl;dr: We encountered a couple crash issues and need your help to determine the risk they may pose!

During our final tests of this latest patch, our team encountered two different crash scenarios, as described below:

  • Issue 1:
    • A rare issue that, after installing the patch, appeared to cause the game to crash on launch for a small number of testers. After a certain number of these launch crashes, the game launched without any issues and the crashes did not reappear.
  • Issue 2:
    • An issue that can cause the game to crash for players when returning to the lobby from a multiplayer session.
    • Theory: This crash may only occur when one of the party members is a Pyromancer and has specific skills (e.g Heatwave or Overheat?) and mods (e.g Tidal Wave?) equipped.

Throughout our ongoing work on Outriders, we only encountered these issues for the first time when testing the latest patch. Using specific reproduction steps, we are able to trigger these crashes between 20% to 40% of the time.

However, our recent community research indicates that both of these crashes may already be present in the game but have never been formally diagnosed until now (because testing didn’t encounter them). If this is the case, then this patch wouldn’t actually introduce any new issues and could be considered “safe”.

So here’s where we ended up today:

  • Option A:
    • Release the patch today, having only partial information about these encountered crashes and running the risk of introducing new issues, including crash on launches, into the game for an unknown number of players.
    • The fixes for these issues would be rolled into the next available patch once we’ve identified and resolved the root cause.
  • Option B:
    • Push back the entire patch to fully understand these issues, fix them, retest the patch for a number of days and then release the patch sometime next week at the earliest. This in turn could also delay the next patch thereafter.
    • Given the already long wait in-between our last and this current patch, we want to avoid delays as much as possible.
  • Option C:
    • Delay the current patch till this Thursday to gather more information about whether these issues (and how often they occur) are already prevalent in the game and how often they may occur.
    • The fixes for these issues would be rolled into the next available patch once we’ve identified and resolved the root cause.

We have opted for Option C and we need your help to determine whether this is the best move to make.

Please let us know in this thread if you feel that you have recently (in the past few weeks) encountered either Issue 1 (Crash on Launch Subthread) or Issue 2 (Crash on Return to Lobby Subthread). As usual, the more information you can provide, the more likely it is that we will be able to identify and resolve them.

What happens next?

  • If we, alongside the community, are able to determine that both of these issues are already present in the game, we will go ahead and aim to release the patch this Thursday.
    • With community data about under which circumstances these issues appear, it will also be easier for us to identify and fix these issues in a future patch.
    • RISK: It is possible that something within the patch has increased the frequency at which these crashes appear, but this will be very difficult to determine in the time we have.
  • If we are unable to determine that both of these crashes are already present in the game, this would indicate that one (or both) of them would have been introduced as part of this patch. The patch would therefore need to be reworked.

We appreciate that this isn’t ideal and not what you wanted to hear today. Whilst we attempt to cover every single scenario in player behaviour and set up, the complexity of gamecode can make this very difficult to do every single time, especially on PC. Even more so under COVID working restrictions where most of us are still required to work from home.

Nevertheless, we are determined to continue enhancing and improving the Outriders experience and will continue to keep you in the loop with the latest. We also very much appreciate all those community members who believe in what we’re trying to achieve and would like to thank everyone for your continued help in making Outriders the best it can be.

External link →
18 days ago - /u/thearcan - Direct link

Crash on Launch - Issue 1 Subthread:

Issue description:

A rare issue that, after installing the patch, appeared to cause the game to crash on launch for a small number of testers. After a certain number of these launch crashes, the game launched without any issues and the crashes did not reappear.

Have you encountered this issue before?

If yes, please let us know if you've noticed a pattern as to when this issue occurs. Please also share your PC's CPU, GPU & RAM combinations.

18 days ago - /u/thearcan - Direct link

Crash on Return to Lobby - Issue 2 Subthread:

  • An issue that can cause the game to crash for players when returning to the lobby from a multiplayer session.
  • Theory: This crash may only occur when one of the party members is a Pyromancer and has specific skills (e.g Heatwave or Overheat?) and mods (e.g Tidal Wave?) equipped.

Have you encountered this issue before?

  • If yes, please let us know if you've noticed a pattern as to when this issue occurs.
  • Please also share your (or your co-op partner's) character's class, mods and class nodes.
    • Of particular interest would be Heatwave and Overheat related information.
18 days ago - /u/thearcan - Direct link

Originally posted by [deleted]

[deleted]

I chatted about this here.

18 days ago - /u/thearcan - Direct link

Originally posted by No-Employment-9979

I have encountered crashes (only a few times) when I click "Login". Always works the second time. I'm on a Series X.

Thanks for the info! Have you found that these crashes are more frequent after a patch release or are they fairly random?

18 days ago - /u/thearcan - Direct link

Originally posted by ohspyder

happens all the time when on my pyro, i run heat wave and overheat on top tree

Thanks for the info - which mods do you use for those skills?

18 days ago - /u/thearcan - Direct link

Originally posted by Nightcrawler_75

Yes this has happened to me frequently...I have been playing since the demo with 1k hours

Thanks for the info - which skills and mods do you use?

18 days ago - /u/thearcan - Direct link

Originally posted by DeadNBuried

Once again sounds like PC. Can you please let us know on which platform you are seeing these issues.

PC particularly for the crash on launch issue, but we're not excluding other platforms from our investigation and it would be valuable to hear from anyone encountering these issues on any platform.

18 days ago - /u/thearcan - Direct link

Originally posted by ginkaiju

I'm ok with pushing the patch to Thursday, but could we have the patch notes please? Are you just dealing with crashing issues or will we also get something more specific like the Borealis set bonus fixed? Thanks

We including information of what would be in the next patch in our recent dev update here.

18 days ago - /u/thearcan - Direct link

Originally posted by unknown-everchanging

You guys have made a wise decision here imo. As a pyro running those skills lately (and im p sure I have tidal wave, that's the width increase mod right?), I have not experienced this bug, disconnecting us on returning to lobby.

Best of luck troubleshooting, and looking forward to the patch :3

Thanks!

Tidal Wave is the below mod:

Heatwave: The skill can be activated 1 more time before triggering the Cooldown.

So you may be relying on a different mod combination. Which is pretty valuable to know in itself given that you said you have a stable experience.

18 days ago - /u/thearcan - Direct link

Originally posted by AtticaBlue

I think it was a mistake to even hint that a patch might come sooner than Thursday. Unforeseen issues always have the potential to arise and sure enough that’s what has happened. Now the devs have a PR problem that could have been avoided—although they’re doing a good job of trying to smooth it out. In future I think it’s better to stick to Thursdays, but if a patch comes sooner than that then it’s just a nice surprise. “Underpromise and over deliver” and all that. …

You make a fair point, but we have to straddle that line between keeping people informed and being called uncommunicative because we're not talking enough.

When we bring players closer to understanding the dev cycle, it exposes all the normal issues developers face throughout years of development. Most other games I've worked on have faced the exact same challenges and had delayed patches and launches, it's just that we're trying to be as transparent as we can be with Outriders.

People may think such issues and delays are specific to Outriders. They're not. We just happen to talk about them a lot more, so you know about them.

Underpromise and over deliver would indeed be ideal, but when you're constantly hounded by "dead game" comments despite all the work our teams are inputting, it's pretty difficult to not explain what's going on behind the scenes.

18 days ago - /u/thearcan - Direct link

Originally posted by Redditer_54

Twice I have failed to join a multiplayer party and been kicked to lobby. The game then freezes and goes black screen. I have to close the game and re launch it as no amount of waiting resolves it. I'm on XBOX Series S.

I am a pyromancer main. I use Overheat, Heatwave and Ashblast. I never got into anyone's game so I highly doubt their character class will have affected the crash.

Edit: I also have tidal wave. Full Atari gear. Can share more of my mods if needed :D

I only use pyro and have always used Overheat and Heatwave and Ash blast when these crash have happened.

Hope this helps :)

I personally feel that you either wait till thursday or just wait until its smoothed out. I've had a real blast playing your game and got some friends to try it out who all feel the same. Thank you for making such an awesome game and being open with the community recently!

Thanks for the info! Interesting to hear that you encountered the crash when attempting to join an MP party (rather than leaving one). That's another angle to look into...

18 days ago - /u/thearcan - Direct link

Originally posted by Fresh-Cup3729

Personal I have around 800 hrs invested and the first 400 hrs were played on the Xbox one x and the second 400 hrs were played on the series x. On the one x I experienced the most crashes. However since I switched to the series x I have not seen any crashes except twice and both were in zehidies upgrading menus when increasing gear attributes. Other then those two instances I have never experienced a crash since I switched to the series x.

A list of things I still have noticed since the game launched. Some of these may already be known and I have just missed the thread that has noted these issues.

  • Schorchlands after you drain the water, that area is extremely buggy/laggy for any players that are not host.

  • Trickster revert time blocks player movement if you’re not the trickster. (The pillar looking thing)

  • Skill life leach seems to stop working still in some instances. More noticeable when playing trickster or techno. (You can be spamming skills and have all skill life leach on armor and weapons and it still will not proc)

  • Moaning winds does more damage when playing as non host. (Have tested this out extensively with friends.) Both players have exact build (character class, armor, weapons, skills, class tree, and mods) the player that is not host will always do significantly more damage with moaning winds and I am pretty sure that this isn’t supposed to be happening.

Other little suggestions for QOL

  • Increase time for CT15 gold completion on boom town, eye of storm, and Colosseum. It’s extremely tough even for a full team with the best DPS builds this would also give the opportunity to use other builds.

  • Removed the invisible wall at start of pillar on Archways as this was never necessary to be implemented when it was during the first couple weeks at launch.

PS: I understand that most of the devs have moved onto the next projects but in my personal opinion Outriders is the best game I’ve seen in a long time. It would be nice if the man power could be reverted back to this and Outriders be made a live service game. A lot of potential and could be a good investment for PCF and SquareEnix again just wishful thinking :)

PSS: Again I appreciate everything u/thearcan an the devs are doing and the constant communication we have seen since before the demo.

Thanks for the post! A few of the things you've mentioned are already on our tracked investigations thankfully.

Interesting note regarding moaning winds though - we have a fix in place in a future patch for a moaning winds issue but im not sure if it's the same one as you describe. Will be keen to hear more about whether the issue persists once we implement our fix.

18 days ago - /u/thearcan - Direct link

Originally posted by xxerexx

This or something very similar has happened since launch for me. Steam, 980ti, 32GB, 3600X.

This or something very similar has happened since launch for me. Steam, 980ti, 32GB, 3600X.

Interesting! Does it happen every patch? Or just fairly regularly? Every day?

18 days ago - /u/thearcan - Direct link

Originally posted by GuiltyCrown127

This has happened to me alot more often after the last update. I didn't think much of it as it reopened correctly the second time. Ryzen 3600x, Radeon 6800 non xt, 16GB ram, 3600mhz

Just to confirm - you're saying it always takes "2 starts" to get going? Since you mention that it happens a lot but it also launches after the second go?

18 days ago - /u/thearcan - Direct link

Originally posted by Larzok

I have a roughly 1in 5 chance the game launches properly, very rarely does the game properly crash. Instead it hangs up on sign in. Usually at "downloading latest server configuration" occasionally earlier in the sequence at "connecting to back end". This happens both before and after cache clears, router reboots don't seem to help or hurt one way or the other. Using an Xbox One (no x/s series or otherwise, terabyte model run). I assume this is part of the already known xbox sign in issues, but adding my bit just in case.

Thanks for the info - I'm very hopeful that precisely this patch will help you with your sign in issue, but we're continuing to spend time investigating it!

18 days ago - /u/thearcan - Direct link

Originally posted by ohspyder

Acari helm - Acari chest with captain hunter - lower armor with ash increased range / exposing strike - gloves with burnt-out / bullet kindling - Acari boots with ashen boost…… using the standard T3 mods on Acari set….weapons if needed to know are funeral pyre and death shield with standard mods

Thank you!

17 days ago - /u/thearcan - Direct link

Originally posted by vapoorer

Thank You for the transparency on the issues.

Yes, I have this issue already and its been like this for sometime. Weeks if not months. However im not 100% sure its the same as you guys have now.

I play on PC and sometimes "I'd agree its rare maybe like 1 out of 10-15x" when starting the game, the game would Crash right after the whole PCF movie. Literally the movie ends and then boom instant crash.

Its like the game freeze on the fade to black screen and i get the pop up crash report window and after like 30 sec the game closes on its own to desktop. I then close out the crash report rather then sellecting to send the report because it takes way to long to send the report and then i try to relaunch the game. Usually it will work but sometimes it might take a couple times or at worst case i have to do a PC restart.

I have alot of hours in outriders. Over 700h. I play alot. So not sure if what i described above is the issue you guys are seeing but let me know. I think i might still have some of the crash reports if that would help.

Other then this crash i mention, i have Zero other crash issues. Maybe i get a random crash here and there but i write that off to normal.

I did have crash issues a while ago "look at 2 previous posts" but those went away. The only consistant crash i get is the one i mentioned above

edit: my pc specs

rtx 3080, 10700k, 32gb 4000mhz cl15, NVME for OS and sata ssd for games.

PC is in custom water loop. GPU and CPU are OC. GPU never goes above 50C and CPU never goes above 60C'ish.

Thank you for the info and details!

15 days ago - /u/thearcan - Direct link

Originally posted by MercwithMouth82

u/thearcan , considering you have been ignoring me for weeks I will bring up again a non-complete summary of people getting wiped again on the current patch.

This time a resource and mod wipe:

https://www.reddit.com/r/outriders/comments/ofsl1b/my_collection_of_mods_disappeared_all_of_them/?utm_medium=android_app&utm_source=share

https://www.reddit.com/r/outriders/comments/oa23i4/logged_in_tonight_and_all_my_mods_are_gone/?utm_medium=android_app&utm_source=share

https://www.reddit.com/r/outriders/comments/o9xj8v/resources/?utm_medium=android_app&utm_source=share

https://www.reddit.com/r/outriders/comments/o8sk67/all_my_mods_disappear/?utm_medium=android_app&utm_source=share

Just to post some of the reports and people getting wiped.

You yourself told me to contact SE support so they could 'help me get back on my feet with a restorarion.'

https://www.reddit.com/r/outriders/comments/o6hlrg/joining_random_expedition_wiped_all_resources_and/h2weer4?utm_medium=android_app&utm_source=share&context=3

And guess what they told me instead of restoring my wiped items? I should restore backups when the game doesn't even have local savegames. Very competent.

https://www.reddit.com/r/outriders/comments/o8sxx5/uthearcan_se_support_wants_me_to_use_nonexisting/?utm_medium=android_app&utm_source=share

Since then radio silence.

From you as well in spite of multiple tags. Funny, considering you were the one that told me to contact support for a restoration. Very classy, but after all you got our money and that's the most important thing, right?

Apologies if you feel ignored, that's not the case at all. There is just so much traffic that I have to keep an eye on that individual cases can often slip through the crack unless I specifically come back to check on them. What are your support team ticket numbers please? I'll get in touch with them to review your case.

15 days ago - /u/thearcan - Direct link

Originally posted by MercwithMouth82

u/thearcan , but it is the case. And not only am I being ignored but also several others of which I even regularly linked some.

  • This is the 3rd time that you have introduced a wiping bug.
  • This is the 2nd time that I (and others) can't play their characters/can't play their characters correctly for weeks. Dismantling weapons doesn't give me mods to my bugged and wiped collection anymore.

It is the 3rd wiping bug introduced to the game and it isn't even acknowledged in your developer updates weeks later.

Here is my ticket number: 00093689

But please tell me what good it should do when your support literally has no idea what game they are supporting? They wanted me to restore backup savegames for a game that does not even have local savegames. How is that possible? What kind of qualifications do your support employees receive when this is the result?

Our support team deals with queries regarding all Square Enix products released. In this matter, you received an answer that you shouldn't have, likely due to confusion on our side, so I do apologize about that. I've asked the teams to review the case and ensure that they look into a satisfactory resolution.






devtrackers.gg