Original Post — Direct link

Whenever I try it simply pops up an R2 saying "Oops...! Something went wrong. Please, try again". But as soon as I refresh the store the LSB no longer shows, as if I had already purchased it or as if it's not available for me.

My brother who plays in my guild also tried buying it for me and it's giving him a message that translates to "Ineligible, due to the game level, purchase limits or account progress"

I'm afraid my account is going through some weird bug and the answer from EAs Support was pretty much "This is a new bug that we are not familiar with, thank you for telling us" but that's it, they didn't say they'd fix it or anything, I really don't want the timer to run off on me and miss on this bundle...

R2 with the lightspeed bundle blurred behind the pop up, showing that I have it available.

Store after refresh no longer showing the bundle

The message my brother gets when he tries to buy it for me

External link →

Can you try now, please?

Originally posted by Lonely-Bluebird9345

It worked, you're an angel ❤️

Glad to hear that!