Original Post — Direct link
Have been playing all evening with hardly any issues, apart from a couple of disconnects at start and a few lag spikes, screen freezing. But I was trying to complete the technician specialization level 5 and had to go to Lincoln Memorial for one of the tasks. First time I tried it wouldn't start as I ran in so as I was running back out I got disconnected and the game wouldn't let me connect again. Closed the game and was greeted with a message from ubisoft connect telling me that achievements could not be saved. Went to restart Ubi connect to find it wouldn't reconnect. And before anyone says anything my internet is fine, I checked my isp status page, did a speedtest and even loaded up a few other games and google chrome and no issues with them.

I restarted my pc, loaded up ubisoft connect and Division 2 again. Went to Lincoln Memorial and again at first it wouldn't initiate. I ran out and back in again and this time it started. After getting through the first 2 gates I suddenly disconnected again and Division 2 would reconnect me to the main menu but as soon as I tried loading up my character again it would disconnect me again. Tried other areas and no problems and even my 2nd character would load up.

Can someone from Ubi look into this for me, I would like to complete my technician spec asap.
27 days ago - ubi-smash - Direct link
Hey Kaylern, my apologies for the difficulties you have been encountering at the Lincoln Memorial. When you have disconnected, did you receive any error code? If so, could you tell me what code the game provided you when disconnected?





devtrackers.gg