Original Post — Direct link

Re: [Unable to use wallet funds to purchase game](/topic/111739/unable-to-use-wallet-funds-to-purchase-game)

I recently tried to purchase The Division 2 Ultimate Edition on sale. I wasn't able to use my debit card right away, but by using wallet funds the purchase went through. The charge hit my debit card account for the proper amount, but the game does not appear on the Ubisoft launcher. I have tried all forms of troubleshooting I could think of, and I have tried everything I could find online. I can now no longer purchase anything on the Ubisoft store and I can't add funds to my Ubisoft wallet either.

10 days ago - Ubi-TheBerry - Direct link

Hey there @Gypsydanger01,

In occasion it can take up to 24hrs for digital content to be delivered, so please allow this time from the point of purchase.

If you're still unable to view / launch the game in Ubisoft Connect, please open a case directly with us via our Support Site, Facebook or Twitter as we're unable to assist with such queries via the public forums.

Thank you!