20 days ago - FatsharkJulia - Direct link

As we release a new patch, you may observe the The strike team you are trying to join is running another version of the game. error even if you have the latest patch installed.

Even if only one member of the Strike Team is running an outdated version, the error will be shown to everybody . We are working on this.

Existing reports may be merged here, to help us keep track of the issues being reported.

16 days ago - FatsharkJulia - Direct link

Re-pinning with the latest update having been released, some of you may witness this.