11 months ago - [DE]Momaw - Direct link

Not a bug. You purchased the Heavy Strike Melee Bundle in the market which includes both the drifter and warframe version of the weapons.  I see the warframe-compatible versions of the weapons in your inventory. You already own everything! (Unless you want duplicate versions for modding purposes)






Recent Warframe Posts