Original Post — Direct link

I’m at the part where you have to “Carry Tedmund.” When I put him down at the target location, nothing happens. It continues to say “Carry Tedmund.” Cannot progress past this step. I’ve tried meditating, fast traveling, and reloading from multiple save points. Still the same issue.

8 months ago - Ubi-Wan - Direct link

@fainterhail7550 Hello there! Our team is still investigating this issue at this time. I'd like to know if you've tried attacking / hitting the NPC in question once, as that's a required action for the quest.

17 days ago - Ubi-Borealis - Direct link

Hello there!

Following the release of TU 1.3.0, the development team has marked the reported issues with "Puppets and Prisoners" as resolved.

If you are still unable to progress in "Puppets and Prisoners," please don't hesitate to update this thread so we can take a closer look. Please include a video which shows the following:

  • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
  • The issue you're encountering when trying to progress in "Puppets and Prisoners."


I'd recommend uploading the video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread.

Thanks! 😊