Original Post — Direct link

hi! i was very much enjoying Valhalla until i came across a glitched world event in Jorvik called "Deviled Water"
i hopped onto the boat where the guy was standing, he jumped into the water and swam away and i destroyed the boat he was standing on and burned every other boat in the harbor.. and that was it! the world event is incomplete and nothing else happens when i talk to the priests!
i looked online with no luck, tried reloading multiple times, leaving the region then coming back, even tried exiting the simulation then getting back in.. all this without any luck!!
please help! this's something preventing me from getting 100% game completion!

i play on Xbox One X with patch 1.0.4 installed.



about 1 year ago - Ubi-Baron - Direct link

@iHolmestark Thank you for reporting this to us.

Just to confirm, if you reload to an earlier point it's still stuck as broken or does it break the same way when you repeat.

11 months ago - Ubi-Woofer - Direct link

Hey everyone, please accept my apologies for the delay since our last reply.

Thank you for your continued reports of this issue with the world event "Deviled Water", and for confirming that it persists even after the game's TU 1.1.1 update. The development team are still investigating the issue, and have requested the save files of affected players (possible for PC and PS4 players to provide) in order to try and reproduce it accurately. Unfortunately, during their previous testing, they did not encounter this issue, so it is one they require affected save files for to look into further.

@iHolmestark Leaving the area of the world event and returning after a time should reset it, however if this is not the case, this is something the team will investigate as part of the overall issue. I appreciate that you are keen to get this world event done in order to fully complete all of the regions for the "Completionist All The Way!" achievement, and I'll do everything I can to get the information the team needs in order for them to try and find a fix. 🙂

@NanoGoo Hey there! Could you possibly confirm whether you're still experiencing this issue following the game's TU 1.1.1 update? If so, as you're on PC, would you consider sending us your save files in a support case? I'd be happy to open one on your account for you if so. Thank you!

@Vryolaka @jdmedlo Thank you both for letting us know that you were able to resolve this issue, and even more so for posting your workarounds / solutions! I hope that these have been helpful to another player in the same or a similar situation. If either of you need additional support in the future, don't hesitate to reach out.

@sicplagu3 Hey! I moved most of your posts into a separate thread here for the NPC / boat for this quest being missing. If you're still having trouble with this issue, please reply there and I'll do everything I can to assist!

@jtwolph @mullhead @Deanouk @veovis77 Hello to you all! If still experiencing this issue with "Deviled Water", could you possibly advise me of the platform(s) you are playing on and also provide a video of the issue if possible? If any of you are on PC or PS4, it would be amazing if you could submit your save files to us in a support case as well so that these can be passed to the developers for analysis. Thanks!






Recent Assassin's Creed: Valhalla Posts

about 10 hours ago - Ubi-Mushy