Original Post — Direct link
Hi mate I am not sure if you have fixed the issue already but I had the same problem and I found a fix for myself so I thought I might share it with you regardless.

When I first installed Anno 1800 I got the message saying that I do not have mfreadwrite.dll.

DO NOT DOWNLOAD THIS DLL SEPARATELY


Download Windows Media Features from the internet according to your Windows version and install it.

Mine was Windows Pro N version 20H2, (The latest update so far) and I cannot download it from the web as there is no Windows Media Features available for download for that particular windows version.

If this is the case for you as well, go to:

Settings > Apps > Apps and Features > Optional Features > Add a Feature and find the Media Feature Pack in the list of available Optional Features and do a reboot.

This fixed the issue for me and I hope it does the same for you if you have not fixed it yet.
26 days ago - Ubi-Milky - Direct link
Hello minhogu0826 and not_wargasmo thank you for sharing your workaround regarding having to install the Windows Media Pack.

To any other players that are facing issue with the game not launching and seeing a 'missing mfreadwrite.dll' error message, please follow the following instructions -

Windows Settings > Apps > Apps and Features > Optional Features > Add a Feature and find the Media Feature Pack in the list of available Optional Features, restart your computer.

Thank you for sharing your workarounds everyone, I will rename this thread so other players are able to spot this solution too.





devtrackers.gg