Original Post — Direct link
This was already asked over a year ago, and I've started playing Anno 2 weeks ago. I didn't know of the bug and to be honest, expected after so much time that everything will be fixed. But, looks like the bug remains. I've found this thread: https://forums.ubisoft.com/showthrea...-Brigade-Quest

But I haven't found an answer. I deleted the original trading post because I thought I don't need it at that moment and continued playing in Sandbox, that was about 80 hours of gameplay ago. Now I have over 150k population and can't get an Air Ship finally when I decided to do quests in the Arctic. I will not reload save game old 80 hours.

Please advice, is there any way to force the quest to continue or at least somehow to get some gas to build the first airship without finishing the quest.

Thank you
23 days ago - Ubi-Milky - Direct link
Hello everyone, thank you for getting in touch with us about The Passage DLC.

In regards to the quest issue you are having, can you confirm if this was with the Ice Brigade quest not being available or greyed out?

If so, we found that if players demolished the Harbour in the Arctic they would receive a warning or the quest would end for some, in this case you would need to reload a save from before the you demolished the harbour.

If this is not the issue you are referring to, would you please confirm the issue you are having with the quest and we can see if this has been reported to the team?
23 days ago - Ubi-Milky - Direct link
Thank you for confirming this dakky22.

This issue was thought to have been resolved from update 10, the Docklands update and will no longer affect players in-game.

If you encountered this issue in-game, with a save file made pre update 10, the team investigating have asked players to reload another save from before demolishing the harbour in the Arctic or to start a new game for older saves. I apologize we have not been able to patch this out of your affected save file.





Links in this thread

Anno 1800 | The Passage | The Ice Brigade Quest | Forums
Hello, I am playing the passage DLC and there is a quest called The Ice Brigage which will not let me continue with the quest by picking up some item. I have tried moving my ship to the place where you need to break the ice, to the Lady's ship and to my harbours but it will not trigger anything. I have also tried clicking everything in the quests but it just replays the message from the Lady. I thought it may be the production element of the quest however as per the 3rd picture I have


devtrackers.gg