Original Post — Direct link

Hello.

Several times now I've been unable to deliver goods for quest missions. In fact, one time I did deliver it, and the flotsam went into the correct clipper, but the game didn't register I had delivered it and failed my quest.
Things I've tried:
-using CTRL+CLICK to automatically deliver to clipper
-dropping item near clipper (this has worked twice, but won't always)
-relogging and reattempting the above

Is there a way to fix this on my end? It seems to have been an issue for a while according to Reddit.

Thanks for your help!

9 days ago - Ubi-Thrupney - Direct link

Thanks very much for your insights into this issue, @casosad - I really appreciate it!

We certainly recommend reloading a save in case of issues, but we'd rather the issues weren't happening at all, of course. If you find you're unable to deliver goods for quest missions, we'd really appreciate a video showing this happening, as this best lets us investigate the issue internally. I know not everyone is able to record footage of gameplay, however. Microsoft has a support article here showing how to use the Xbox Game Bar to record gameplay footage.

Thanks for the reports, everyone. Let me know if there's any questions at all, or if you continue to run into this issue.