about 1 month ago - Toolguy - Direct link

Just another minor upgrade

1.3.8 (22 january 2021)

  • The status bar should not appear truncated anymore if the launcher is started on a very small screen width (like a tiny Remote Desktop Session)
  • Removed the “Close Steam” option
  • Renamed “Stream Query Port” to “Source Query Port”
    Dedicated Server Launcher 1.3.8

Not much on the outside, but I did a bit of cleaning in the code, keeping the “Technical Debt” in check.

about 1 month ago - Toolguy - Direct link

Are you sure it’s the Tool (Dedicated Server Launcher) that require Direct X, or is it the actual “Dedicated Server” game?

Like, do you get an error when trying to run the tool, or is when trying to deploy/launch the game server?

about 1 month ago - Toolguy - Direct link

I’ve honestly no idea regarding this Core Server, I would personally suggest asking to the OVH people, they probably know about that, I doubt you would be the first person encountering this issue :slight_smile:

about 1 month ago - Toolguy - Direct link

Idéalement l’Anglais est recommandé, ca augmente les chances que quelqu’un d’autre puisse aider.
Est-ce que les autres messages apparaissent, si vous mettez un message en bas a droite et appuyez sur “Send” est-ce que le message apparaît? Si non, est-ce que vous avez bien activé RCON avec un mot de passe?

about 1 month ago - Toolguy - Direct link

Don’t you have the backup feature enabled?
The whitelist is supposed to be saved with the rest of the files, is it also wiped in all the backups?

about 1 month ago - Toolguy - Direct link

Typiquement ce genre de changement, il faut le faire quand le serveur ne tourne pas: Il arrive souvent que le serveur décide de réécrire les fichiers INI, et tout ce qui a été modifié dans le DSL entre temps est annulé.

Pourriez vous tenter ca.

  • Stopper le serveur
  • Mettre le mot de passe RCON
  • Cocher “Enable” RCON
  • “Save Changes”
  • Démarrer le serveur
about 1 month ago - Toolguy - Direct link

Whitelisting IN GAME with the console commands does work fine, but doing the same thing with the rcon command, breaks the whitelist file?

23 days ago - Toolguy - Direct link

I believe these are two separate problems:

  • For the “can’t connect”, there’s a know issue with accessing the server from the same local network, so if you are on the same network, instead of using the external (public) IP, try the local IP of the server and see if that helps.
  • For the fact it does not show up on the list, I thought that was fixed, but apparently no (could be many things), so one thing you can do is to setup a discord webhook and have your players join it, when the server start it will say that the server is ready and can be join, so your friends can use “direct connect” on the specified IP and port.

See if that work, then we can eventually look at the details about why your server does not appear.

19 days ago - Toolguy - Direct link

Weird, I’ve heard of “losing the password”, or things like that, but never losing it all.
So let’s start by the begining:

  • Which version of the Dedicated Server Launcher are you using?
  • Any reason why you are not pressing the OFF switch instead of closing the window (not that matters, just to know…)
  • Have you setup the backups so you get a copy of the ini files, gamedb, whitelist, blacklist, etc…

Now, just to figure out if it’s the launcher or the server, one thing you could try is

  • Click on the top line that shows Server XX/YYYY (path to the exe) to open an explorer window to the game server
  • Click on the blue icon with a gear at the bottom left, to open an explorer window to the ini files
  • Make sure all your settings are correct
  • Press Save Changes
  • Quit the Dedicated Server Launcher

Then, multiple time try that:

  • Check in the Game.Ini, Engine.ini and ServerSettings.ini that all the parameters are correct
  • Manually launch the server from the explorer window
  • Close the white empty window

If at some point the settings disappear, then it was something in the server itself, not the launcher.

Edit: My game config was also reset to default, WTF???

Do you see any warning or errors in the game server logs?

18 days ago - Toolguy - Direct link

KDS error messages are common, and not always a sign of a problem.

When you write “unable to connect to mine”, can other persons outside your network connect properly?
If it’s just you on the same local network, have you tried “direct connect” with the local IP of the server?

18 days ago - Toolguy - Direct link

Do you see attempts at connecting in your server log?
A common issue is firewalls making the “handshake” to fail, the connection protocol starts, but at some point it fails and a time-out happens.

18 days ago - Toolguy - Direct link

Problem solved: It was a firewall issue.

17 days ago - Toolguy - Direct link

What is the setup?
Are you both playing from outside, is your friend outside and you on the inside (same local network)?

17 days ago - Toolguy - Direct link

That’s unfortunately a problem introduced last spring with the FLS version of the game, on many network configuration the server is not able to translate the external IP when it comes from the same local network, so if you want to play, you have to Direct Connect using the local IP of the server, which is annoying for sure.

Regarding the ports, well, both the client and the server are using a set of port, and the first one started locks out the port, so using different set of ports is a good idea, yes, and that’s in the FAQ in the top post.

15 days ago - Toolguy - Direct link

To me it looks like for some reason SteamCMD is trying to parse a HTML file like if it was supposed to be another type of files with “key and values”, maybe there was a network outage, and the Steam Servers returned a webpage with an error code instead of what SteamCMD was expecting.

There’s unfortunately not much I can do, my tool can only use SteamCMD to fetch files, and when SteamCMD is not able to fetch the files…

I tried to contact Valve to see if there was any outage on their side that could explain that (you are not the only one having these weird errors since last week), we will see how that goes.

11 days ago - Toolguy - Direct link

Question to everybody around: Should I push 1.3.8 as the new official version, replacing 1.3.7?

Links in this thread

Conan Exiles Dedicated Server Launcher (Official Version: 1.3.7 / Beta: 1.3.8)
Our Tools Programmer Mickaël put together a tool to let you more easily set up and run a dedicated Conan Exiles server. After a few rounds of iterating, we wanted to make this tool available to you guys for testing and f…

Technical debt - Wikipedia
Technical debt (also known as design debt[1] or code debt, but can be also related to other technical endeavors) is a concept in software development that reflects the implied cost of additional rework caused by choosing an easy (limited) solution now instead of using a better approach that would take longer.[2]