3 months ago - Toolguy - Direct link

Is is the Server Log content displayed in the Launcher for your comfort, it’s not generated by the Launcher, it’s just the content of what is in the Saved/Log folder.

3 months ago - Toolguy - Direct link

Sounds good, thanks :slight_smile:

Hopefully we will find a better solution that works on the long run!

Probably not related, I don’t remember having added some awesome optimisation between 1.2.5 and 1.3.1 :smiley:

Yeah the documentation is like the tool, it has grown organically, do you have suggestions of what I could do to the documentation that would make it easier to use, or possibly some out of date stuff, etc…?

3 months ago - Toolguy - Direct link

As @drachenfeles said, these are not errors, they are statistics sent to a monitoring server which checks which servers are running, with how many players, and the associated memory/cpu usage.

This is used to figure out if for example a code change in a new version of the game ends up gobbling up more memory or crashing more often.

3 months ago - Toolguy - Direct link

First, one important thing: If you don’t get the green light, don’t even bother continuing: The server will not be usable.

Second, if you are planning to use the Conan Exiles game client on the same machine, then you will have conflicts because the client uses 7777, 7778 also by default, so for the server you should use something else like 7780, 7781, for example.

I have opened ports on my router

By open, you mean “open” or do you mean “forwarded”?

Open is just a firewall thing, it says that outside information is accepted instead of rejected, it’s like telling the bouncer at the entrance of the club that “yeah, you can enter”, but that’s only one part of it, this information need to reach the right machine, and that’s the “forwarding” part (to continue on the metaphor it’s like “go in the third room on the left in the corridor on the first floor”).

For a proper forwarding, you need to:

  • Have an ISP/modem that actually support port forwarding - some internet service providers infrastructure make that impossible.
  • Write down the Mac/Hardware address of your server (you can see that on the Dedicated Server Launcher just above “Test Port Accessibility” with a “copy” button so you don’t have to actually copy it manually.
  • On your router, give a fixed/static IP to your server so it does not change when you reboot, but disabling DHCP for this Mac/Hardware address.
  • Then you need to forward the three first ports (Game Port, Raw Port, Steam Port) to this fixed IP, for BOTH UDP and TCP.

At this point, if the Test Port still does not work, I suggest to temporarily shut down all the firewalls and anti-virus (on the server, on the router, on the modem if you have one, …), see if that works. If it does work, it means that one of these is wrecking havoc, so enable them back one by one until it stops working, which means you found the one causing problem -> investigate the settings, and make sure both the Game Server and the Server Launcher are being allowed.

That’s about all I can say, until you get green light it’s pointless to try to run the server :slight_smile:

3 months ago - Toolguy - Direct link

There’s a known issue there, where in some cases computers on the same local network are not able to connect using the external ip, but can when using the local ip (that means “using direct connect”)

Since port forwarding does not see to work for you, could you give me the exact name/model of your router, and which ISP/country you are are using?

3 months ago - Toolguy - Direct link

It’s IP:PORT + Password, you need to specify the game port after the IP

I’m using a Netgear r6400v2, I’m in Belgium using VOO as network provider.

Somebody suggested to reset the router: https://forum.voo.be/conversations/ma-connexion-internet/port-forwarding-ne-fonctionne-plus/5e53e4814cf00d702bf74068 (from 2019)

Based on what I read, it looks like contacting VOO’s support could be a good idea, apparently some people have a configuration that does not allow port forwarding:

https://www.informaticien.be/forum_topic-6866--VOO__pb_avec_NAT_.html (from 2013, so a bit old):

Les abonnements domestiques, pour les petites formules portent le doux nom de CGN,
En clair, ca veut dire double NAT.
Il t’est donc impossible de sortir en VPN, ou de router du trafic de l’extérieur vers l’intérieur.
Ce qui dans ton cas t’empêche de router le trafic externe vers ton port 80 vers l’ip interne de ton serveur Web.

Donc, d’un point de vue technique : Oui tu as de l’internet donc pour le brave gars au support, tu es un idiot qui ne sais pas faire de NAT.

D’un point de vue pratique, le flux n’est possible que dans un sens; ce qui ne t’arrange pas.

Afin de résoudre cela : appelle le support Voo et tu leur dis que tu es en CGN et qu’ils doivent changer cela; ca demande 5 min de config chez eux et le reboot du modem.

3 months ago - Toolguy - Direct link

I would just contact the VOO support and ask them :slight_smile:
I’ve never done port forwarding on a 4G modem, I’ve no idea if that’s actually possible.

3 months ago - Toolguy - Direct link

This will probably change in some version not that far down the line: I had way too many problems with values disappearing, which is why I introduced the “Launcher.ini” where I will start migrating the values, and they will be the “authoritative ones”, which I will keep as a base to update the actual game server ini files.

When that’s done, I’ll documenting that :slight_smile:

3 months ago - Toolguy - Direct link

Well yes, some people are running more than one game server on the same physical machine, each game server use a different set of ports, and each set of port is forwarded on the router.

3 months ago - Toolguy - Direct link

@Frostie @Eldin89 the message you are getting is from the game itself, that has nothing to do with the launcher version you are using (the only place where the launcher is involved is the detection of updates, which may or may not be working as expected)

When you launch the server from the launcher, what happens is:

  1. The launcher starts SteamCMD telling it to update the server and the list of mods
  2. The server is started
  3. The server checks the mods

The point 1 only happens if you have setup “update on startup” in the launcher, else it skips directly to 2.
The point 3 is something recently added by the dev team to limit the compatibility issues between the game and mods and still being worked on.

So just to touch on this, mine is doing the same but we are running 1.3.0, should I update to 1.3.1 and see if that works? Multiple mods updated last night

If you look at the Release History the only difference between 1.3.0 and 1.3.1 is:

Fixed a bug introduced in version 1.2.5 with the “Test Port Accessibility” showing grey instead of red lights for errors.

Updating will not hurt, but it will not change anything to your mod issue :slight_smile:

3 months ago - Toolguy - Direct link

As @drachenfeles wrote, this is a part of the game/balance changes the Exiles team is doing, that has nothing to do with any settings on your side or that the Dedicated Server Launcher is doing.

Glad you managed to get it working :slight_smile:

@Tovan_MacKelly @Sulvix The team is tying to come up with solutions to make mod issues easier to diagnose and fix, but yeah at the moment it’s a bit painful, sorry for that.

3 months ago - Toolguy - Direct link

That’s on the top left: “Check for Updates and Restart” and the number on the right is how often the check is performed (default is 00:05 which is “every 5 minutes”).

You can also click on [?] to show you the current state of what you have installed and what the current versions on Steam are.

3 months ago - Toolguy - Direct link

For that you need to have RCON working, which means:

  • Enable the RCON checkbox
  • Have a valid RCON password
  • Make sure the RCON port is not used by something else
  • Use “Broadcast” if you are using a vanilla server (will show a big message box dialog)
  • Use “Server” if you have Pippi mod installed (will show the messages in the chat instead)
3 months ago - Toolguy - Direct link

Do you get all the green lights when you test the ports?

Normally friends of yours (outside your local network) can just use the server browser list in the game - assuming the port forwarding is properly done, and that all the firewalls are properly setup as well.

2 months ago - Toolguy - Direct link

You do need the three ports forwarded, in both TCP and UDP.

Ideally you want to make sure that 192.168.1.4 will never change, so whatever router you are using, make sure to not use DHCP for this PC but instead to associate the IP to the MAC/Hardware address of the network card of this machine (it’s displayed on the network section of the launcher, with a small button to copy the value so you don’t have to type it manually).

If after that it is still red, it either mean that:

  • Your ISP does not allow port forwarding
  • Or that you have another part of the system that blocks the port forwarding (could be another modem not bridging data properly, could be one of the many firewalls people have, could be an anti-virus, …)
2 months ago - Toolguy - Direct link

What’s your screen resolution, and which fontsize/dpi have you selected?

2 months ago - Toolguy - Direct link

Ok, I don’t a 4k screen here, I tried with a 2560x1440 screen at 200% and the tool behaved properly.
Could you try at 100% and if that works well, then 200%, and if that still works, go higher until it starts misbehaving, maybe it’s an overflow in the rescaling code, but without being able to reproduce this type of bug it is hard to fix :slight_smile:

So you confirm that the display is correct when you launch the program, it only clips when you try to move it or resize it?

Have you try to minimize and then restore it?

about 2 months ago - Toolguy - Direct link

It’s common for mobile subscriptions to not support port forwarding, some allow it, but generally it’s different types of subscriptions that only some ISP/telcos provide.

That being said, some people managed to bypass that by using VPNs (not sure how it worked for @deathshand958 with his attempts with the “Hamachi Virtual Ethernet”), knowing that this would only work for a very limited number of people, because the impact of the VPN on the performance is quite significant.

about 2 months ago - Toolguy - Direct link

Does the tool display properly on the 1080p screen?
This type of bug is typically super hard to fix when it can’t be reproduced.

Question: Does the tool appear first correctly on one of your screen, and then you move it to another screen that has a different DPI setup?

It’s possible that my code is failing on something related to querying size information on the wrong monitor when doing moving and resizing. (I’m using a combination of WM_GETMINMAXINFO and WM_SIZE, but maybe I should also track WM_DPICHANGED…)

about 2 months ago - Toolguy - Direct link

Imo the next step is to check the logs for errors, specially in your case, the actual Dedicated Server Launcher logs, they are located in the DedicatedServerLauncher\Logs folder at the same location as where you’ve put the launcher executable, all the logs are named “DedicatedServerLauncher(x.y.z).*.txt”






Links in this thread

/u/sulvix


/u/tovan_mackelly


/u/drachenfeles


Conan Exiles Dedicated Server Launcher (Official Version: 1.3.1 / Beta: -----)
Our Tools Programmer Mickaël put together a tool to let you more easily set up and run a dedicated Conan Exiles server. After a few rounds of iterating, we wanted to make this tool available to you guys for testing and f…


/u/eldin89


/u/frostie


VOO : pb avec NAT ? - Informaticien.be


https://forum.voo.be/conversations/ma-connexion-internet/port-forwarding-ne-fonctionne-plus/5e53e4814cf00d702bf74068


/u/deathshand958


devtrackers.gg