17 days ago - AndrewT - Direct link
andrew_the_cat said: Just tried rolling back to older versions, they still run badly, even though they ran fine earlier in 2021.
That pretty clearly shows this is some local issue in your machine, rather than a game problem as such.

Does that also affect say CK2, EU4, HOI4 or Stellaris?


DXDIAG is a program you run from the Windows search box on the task bar. After running it will open a window and start collecting info with a progress bar in the lower-left corner. When it completes click the 'save all information' button and save it to a file then attach that file here.

Please attach here your Documents/Paradox Interactive/CK3/pdx_settings.txt .
From your Documents/Paradox Interactive/CK3/logs/ folder, attach here system.log , error.log .


Please report the temperatures of your CPU and video (GPU)
1/ before starting the game up and
2/ after say 10 minutes' play.
If your PC's vendor has given you no way of reading temperatures, install
SPEEDFAN http://www.almico.com/sfdownload.php  
16 days ago - AndrewT - Direct link
When you say it is the same, is this also true of you?
Just tried rolling back to older versions, they still run badly, even though they ran fine earlier in 2021.

What I can see in that dxdiag is your Intel HD 620 video system is unsupported by either game; it is significantly weaker than the minimum requirement for this game, the Iris Pro 580:
UserBenchmark: Intel Iris Pro 580 (Mobile Skylake) vs UHD Graphics 620 Kaby Lake R)
And IR does not support any Intel video systems at all.  
16 days ago - AndrewT - Direct link
So again, if older versions of the game used to be fast but now are not, this is a local problem rather than issues with the latest game patches. We're basically reduced to guessing what might have gone on in your machine/Windows to have caused this.

Were you unable to locate the other files I asked for? Did you check the temperatures as I described?


Check if Windows is in Games mode, if so undo that.

If you have these apps/utilities running, please unload them as a test: MSI Afterburner, Citrix Workspace, any other performance management/enhancement utilities  
15 days ago - AndrewT - Direct link
CK3 has no settings.txt , that was an error on my part. I see no cause for this problem in those files.

Did you check the temperatures as I described?

Try editing that pdx_setting.txt file, make this change:
"renderer"={
version=0
value="OpenGL"
}
Does that change things at all?  
15 days ago - AndrewT - Direct link
FPSeph said: The pdx_settings file now displays DX11 as its renderer
I know that, I'm suggesting changing it to OpenGL as a test

FPSeph said: I checked the temperature and ingame it varies between 65-75Cº
That's getting up there, but not quite to the level that causes problems, which is normally 80c. It never gets over that?

And is this for BOTh the CPU and GPU?  
14 days ago - AndrewT - Direct link
FPSeph said: -I finished installing any pending updates for Windows.
I have seen that cause performance problems with our games. Your Windows version did not show that it was out of date though.

FPSeph said: -I used the Program Compatibility Troubleshooter, that was what made the main menu work normally although at first it didn't solved the framerate drop ingame
Not normally necessary of course. I wonder what change it made?

FPSeph said: -I noticed that when I lauched the game my pc woudn't slow down, normally it would since the game was running but when the framerate was at 1 it wasn't happening, this makes me think that the game was probably not using the necessary amount of memory it needs to run smoothly.
Nothing you've done would change that, so far as I can see. If the game could not get the memory it needed to run it would crash.

FPSeph said: -The Dxdiag showed that my Dx version was 12 not 11, I don't know if this could be the reason for the issue but since the game is normal I suppose not
You have DX9, 10, 11 and 12 all installed and available for apps to use, as does every installation of Win10/11. Dxdiag just shows the highest and default one.

So I frankly have no idea what caused your problem, with the possible exception of that first item there.