Original Post — Direct link

Greetings all,

After downloading the 9/15/22 patch my For Honor fails to launch (Steam). It quotes a Disk Write Error. I had l just purchased the Season Pass so I was able to get the game started and running once, but I closed the game to bind the pass to my account and my forhonor.exe file was deleted again. I don't believe that it is an issue with my antivirus because I disabled it and tried to redownload the patch, no no avail. I'm open to reinstalling the game, but I'd rather avoid that. I think that some others have already taken to Reddit about this issue, but there's been no fix there and I'd like to progress on the Pass that I purchased and can no longer have refunded.

Edit: Some other things that I have now tried are: I have emailed (made a ticket with) Ubisoft, tried to manually install an executable file (forhonor.exe) that I got from a friend, repaired my steam folders, cleared my cache, restarted my PC, heck I've even uninstalled and reinstalled twice. I'm really getting frustrated at this point, if I'm being honest.

Anyone else having this issue? Maybe we can try to think something up, you can hit me up on Discord @The Bear#8008

11 days ago - Ubi-DeskLamp - Direct link

Heya @Lord_Bear, sorry to hear that For Honor's not wanting to work for you!

Since you're getting that disk write error, can you try defragmenting your hard drive as a first step if you haven't already?

If defragmenting doesn't help, please make sure you've not missed any of our basic technical troubleshooting steps for PC, and then update the thread if that doesn't help either!

9 days ago - Ubi-DeskLamp - Direct link

I'm glad to hear that you managed to figure it out, @Lord_Bear! Please make sure to let us know if you run into any other issues! 🙂

6 days ago - Ubi-Mark. - Direct link

Hello @Tomos34,

Thanks for reaching out and I'm sorry to hear that you are experiencing the same issue.

Can you please confirm if you tried all of the steps provided by us and @Lord_Bear, by any chance?

Many thanks and if you have any additional questions, please let us know.

@Lord_Bear - thank you for sharing!

6 days ago - Ubi-DeskLamp - Direct link

@Tomos34 To clarify then, is Ubisoft Connect also on the same drive as For Honor? If not, please try reinstalling Connect to said drive.

Once they're both on the same drive, you can also try running both Connect and the game as an administrator if you're still having problems!