Original Post — Direct link

Posting on Reddit to hopefully get some actual mod support rather than a canned response...This all happened last night (2/7/2024 around 19:30 EST). My in game name is Giant Doop, and our group name is Size Matters.

Last night, when putting our group's dragonhunter lance in the group storage, the storage system buffered for 20-30 seconds when I hit "Save". I then received the message of something along the lines of "Failed to save group storage." Lo and behold, the lance was no longer in my inventory. Full of anxiety, I tried to open the storage again - about 30 seconds then the message "Unable to load group storage." Tried again - same result. I logged out and tried to log in again and received an error code of something like "Failed to reach login server." I had another group member go to a bank and try; he was also unable to open our storage (same error message).

Two to three more minutes pass by, and I'm able to log back in and open the group storage. Unfortunately, the lance was not in there. I triple checked my bank and inventory - nothing. Poof. Gone. Vanished.

At the time, only two other members were online, and I was in a discord call with both of them. Neither were near a bank; one was serving time in the red prison, and the other was in the slayer tower killing aberrant spectres. I've known both of these gents for almost 20 years - no reason to suspect foul play (also, neither of them even knew I was putting the lance back in).

I messaged Jagex Support through their "Lost Item" section of the site and received what seemed like a canned, automatic response of

"You indicated in your message that you lost your items in Old School RuneScape. Unfortunately, as described in our lost items policy we're unable to return items due to technical limitations with the game.

I understand this isn't the news you were hoping for and how frustrating this could be, but is a service we're simply unable to provide support for."

...on the "Lost Items" section of their site, it literally says they will try to replace "loss of GIM items cause by storage malfunction. So what gives? They were able to help Farmers v2 out for a similar issue; why can't I get a non-automatic reply from a mod? This was completely out of our control and to be honest, it sucks. Between myself and another group member, we have spent close to 100 hours doing hydra for this drop. If it was actually my fault that I lost it, I would accept responsibility, but it wasn't...

Anyway, I'm just hoping that maybe Reddit will make a Jagex mod care enough to look at our group, maybe see that there was an error in the storage system around 7:30 EST, and care enough to reply and/or give our lance back.

External link →
23 days ago - /u/JagexTyran - Direct link

GIMs losing items due to the storage issue is handled outside of the regular lost items return process - it’s handled behind the scenes without the need for contact, I can confirm you’ll get your lance back shortly, and it’ll go to the bank of person who attempted to store it. :)






Recent Old School Runescape Posts