Original Post — Direct link

I've been trying to play rainbow after a few years of not playing cause I got the urge to but I haven't been able to play because of this connection lost screen. It's not my connection and I don't know how to fix it. Every other game I want to play works fine but just not a rainbow, the only time I was able to play was yesterday and that was after I restarted my router but after I logged out and tried to play again nothing worked and I can't play the game. all my friends can log in fine but just not me?

  • I don't use VPNs
  • No extra software in the background
  • Drivers are all up to date
  • the latest version of uplay is downloaded
  • Did a network reset (no luck)

If someone can please help me out that would be great
Discord- kyoki#0999
Twitter- @MadnessVI

about 2 months ago - ubi-smash - Direct link

Welcome to the forums @kyok! Sorry for the trouble you are having with trying to play Rainbow Six Siege. From the message shared in your screenshot, I would check if emptying the cache of Ubisoft Connect may help remedy this issue. If you have already ensured that you have the latest version of Ubisoft Connect reinstalled, also make sure that Ubisoft Connect is set to run administrator rights. Let us know if the error continues after trying this out, and please keep us posted if you have any other questions. Thanks!

Recent Rainbow Six Siege Posts

about 1 hour ago - UbiMark