Original Post — Direct link

Hello, ive recently started playing trackmania 2020 after playing a lot of tmnf. I wanted to try the royal gamemode with my friend, and so we did, for about 3 games, then we ended the day and went to sleep. The next day we wanted to play again but the game doesnt seem to be loading me, whenever i try to load on the royal server, i just get a map animation and after few seconds i get and overview of the map which i can move with right click, but also everyone else is already playing and i cannot even disconnect, my only option is restarting the game and even then when i try to reconnect the same thing happens. This happens even if i load quicker then my teammate, i tried starting as administrator, verifying the game, reinstalling the game, all my drivers are up to date. Im honestly out of options, Can anyone help me solve this issue ? Also im playing with the starter access, but the royal mode should be playble with this access, shouldnt it ? Thanks.

13 days ago - Ubi-Havoc - Direct link

Hi @petasuss welcome to Discussions! I've merged your threads together here to look into this issue when loading into the royal gamemode. It looks like you've already tried out a good amount of our troubleshooting steps for technical issues on PC so I am sorry to see this loading is still persisting.

Could you next try out our connectivity guide here for PC before starting a new game in the Royal gamemode? Let us know if that has any improvement in joining your friend once more.