Original Post — Direct link

When I start a new game on Story Mode after the new patch, Madame Kahina and Eli Bleakworth both show as "you have no trade rights", while the pirates are peaceful and also don't show up in the diplomacy screen.

I doesn't seem to affect Sandbox games.

I've tried rechecking all the files.

Please help!

10 days ago - Ubi-Thrupney - Direct link

Thanks very much for your post about this, @teszes - welcome to the forums!

I understand that you've not been able to trade with Madame Kahina and Eli Bleakworth, and the pirates aren't showing on the diplomacy screen. It's great to hear you've already verified your game files, but really unfortunate that this hasn't solved the issue.

Can you send me across some screenshots showing this trade rights issue, and that pirates aren't showing up on the diplomacy screen? You'll find our guide on how to take screenshots here.

With some screenshots, I'll be able to make sure this gets investigated promptly by our teams. Thanks once more for your help with this - we really appreciate it!

3 days ago - Ubi-Karl - Direct link

Hey everyone, thank you for your input regarding both of the issues as well as screenshots sent by @SirHarryPierce - great effort all around.

In relation to not being able to trade some of the campaign characters - I can confirm that information provided has now been forwarded to our development team for further review.

As far as diplomacy with pirates go - if any of you have save file where this particular problem is present (same goes for the initial character trading issue), could you possibly share it with us? This will be greatly beneficial for reproduction purposes. For details on how to locate it on your PC, have a look at the following article.