Original Post — Direct link

Hello,

I'll attempt to make a long story short. I've had a ton of problems after I came back to test Anno 1800. I bought a Ubisoft + subscription (only to play Anno), and noticed that the game failed to launch for a lot of people after the last update (the launcher is stuck on loading).
I have after being unable to play the game for around 2 weeks, found that if you reinstall the Ubisoft Connect application before launching Anno, you will be able to play the game. Meaning that every single time I want to play, I need to uninstall, reinstall, log on and launch the game. If I exit the game and try to relaunch, I will be stuck with the loading error. Please look into this issue!
I have also monitored information posted about this issue and tried every single "fix" suggested without it being any helpful.

I've tried to adress my problems in various tickets since the 11th of December, but I've yet to receive a normal response to any of my questions I've posted. You simply wait a few days and send me an auto generated answer, which i reply does not help, then you wait a few more days and do the same thing. I have not received a response towards any of my actual questions in the tickets I've made. The customer service you provide is so dreadful, and it's been almost 4 weeks since I first contacted your.

20 days ago - Ubi-SleepyGoat - Direct link

Hey there everyone.

If you have not already done so, please ensure that your Windows installation is on the latest version, as this fixes this issue for almost everyone experiencing it. For Windows 10, this version should be labeled 19042.2486

If you have this version installed already and you are still not able to launch the game normally please let me know.