Original Post — Direct link

I have a problem and I've seen several people with the same problem.
I started a sandbox game recently (23/07/2022), after I was close to LVL 45, I went to Cape Trelawney. There I even received the mission to get close to Old Nate's Lighthouse (I even saw the little arrow on top of the Lighthouse), but when I got there with a ship, the mission disappeared and I can't continue the mission.
I was supposed to receive Savage and do the first dive missions to get scrap, but I don't receive Savage and it doesn't even show the mission and places where the scraps are for the first dives

I've seen several people with the same problem. Always when they take too long to do the Expedition for Sunken Treasures.
I tried to add the "Spice-it-Up" Mod with the "Buildable Salvagers" module only, as some people said that after building the Savage in the port itself, the next step of the quest was corrected and shown in the quest book. It didn't work for me. Even, now I can delete Savage, and Old Nate giving me the option to buy another one. But when I buy another Savage, the quest it still doesn't appear.

There seems to be a problem related to the quest to receive Savage to be able to go looking for the first treasures, not appearing in the quest book, and not following it up.
I already had this same problem in the year 2020 or 2021 (I don't remember well), and it was exactly the same, the arrow appeared to get to the Old Nate Lighthouse, but the mission didn't followed up.

I'll leave my Save here in case it helps, but I don't have older saves because I deleted it, it took up too much space.

Note: The ideal solution would be for the game to check if the quest has already been done, and if not, put it again. Creating a game at the beginning only to make it again is a waste of playing days. And nothing guarantees me that quests from other places I haven't been to won't be a problem in the future either (Arctic and Enbesa).
Note 2: I've already repaired the game files, reinstalled the .NET Frameworks, checked DirectX,disabled programs at startup, repaired Windows, and nothing worked. Sounds like a programming problem in game.

Save Link: https://drive.google.com/drive/folders/125ZpFy8fKVe7A0YdhhG_8Qx4STcG0pmw?usp=sharing: (https://drive.google.com/drive/folders/125ZpFy8fKVe7A0YdhhG_8Qx4STcG0pmw?usp=sharing)

about 2 months ago - Ubi-TheBerry - Direct link

Hey there @viniciusmi00,

Thank you for reaching out to us and reporting this, sorry for the delay in getting back to you!

I've passed your report onto the team to investigate this further.

So we can add it to the report, could you please also share a screenshot or video of your current position in game / current mission?

Much appreciated!

23 days ago - Ubi-MrM - Direct link

@viniciusmi00 No problem, thank you for the video !

It has been forwarded to the Team, and we thank you for it !

We'd like to ask you a few questions as well, in order to isolate the Issue :

👉 Can you provide us with saves where Sunken Treasures quests are available ?

👉 Was the World Fair built before reaching Cape Trelawney ?

If you'd like to share additional information, or have any questions, don't hesitate to reach out !