20 days ago - /u/UbiArcane - Direct link

Hey everyone,

Thank you all for the feedback, memes, and clips you have been posting. Rest assured, this subreddit is read everyday by us. We wanted to start a thread to see everyone's thoughts on the weapons, hacks, and overall game after our Open Beta patch. Please let us know your thoughts!

External link →
20 days ago - /u/UbiArcane - Direct link

flair: official

19 days ago - /u/UbiArcane - Direct link

Originally posted by Austinheller12

On mobile so I apologize for the poor formatting. The game overall is extremely fun and a very refreshing style of BR. I’m one of the few who believe TTK and weapons/hacks are in a pretty decent state and may only need a few minor tweaks.

The biggest issue I have is the consistent stuttering throughout matches. I’ve tried every “solution” this subreddit/United forums has offered and I will admit I’ve noticed some slight improvements, but not enough to thoroughly enjoy the game. It appears that there are a lot of others with low-high end PC’s who are also having similar issues.

My initial thought was that this was related my PC, but now I’m beginning to think it is server side (few games with latency/connection icon), but after trying all the below “fixes” I’m at a loss.

Fixes I’ve tried:

Run Uplay as administrator

Run Hyper Scape as administrator

Verify game files

Reinstall Uplay/Hyper Scape

Disable full screen optimization/DPI scaling

Hyper Scape priority to High (BE.exe as well)

Uplay priority to low

Clean boot / close background applications

Delete temp files

Flush DNS

Port forwarding

Manually change server in .txt file

Settings on low / settings on high

Frame rate cap

Mouse acceleration off

Full screen, borderless, windowed

Edit - format

Hello! Sorry about this stuttering. Have you made a case with support.ubi.com? If so, would you DM me your case not. If not, would you please make a case with our Support Team and include your dxdiag and msinfo, (then DM me the case number) so we can investigate further.

19 days ago - /u/UbiArcane - Direct link

Originally posted by UbiArcane

Hello! Sorry about this stuttering. Have you made a case with support.ubi.com? If so, would you DM me your case not. If not, would you please make a case with our Support Team and include your dxdiag and msinfo, (then DM me the case number) so we can investigate further.

flair: ubi-response