Original Post — Direct link
Hey! looking for some help, I've had many problems with Uplay connectivity issues but this one I cant seem to fix, whenever I open rainbow six siege (through steam) its opens the Uplay launcher and logs in and then gets stuck on initializing and gives me the option to go offline and sign in, I have tried restarting, uninstalling programs, turning off firewalls and antiviruses but nothing seems to work

Help?
over 4 years ago - UbiCovah - Direct link
Hey, valskell79!

Are you still experiencing this issue? Are you using the most recent version of the launcher? Have you tried these connectivity steps? Are you able to access your account?

If you need additional assistance, please feel free to create a ticket at support.ubi.com so that a specialist can help. Remember, you can reach out to our dedicated support teams on Facebook or Twitter.that are always happy to assist.

Thanks
almost 4 years ago - Ubi-Karl - Direct link
Hey jsven007,

Thanks for reaching out to us and I'm sorry to hear about the issue you ran into.

In order to resolve this, please try running Uplay as an administrator. to do this, go to the following location:

1. C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher
2. Right click Uplay.exe
3. Select properties
4. Switch to the compatibility tab and tick run this program as an administrator.
5. Click Apply and then OK

Should issue remain, let us know!