about 1 year ago - AndrewT - Direct link
AngelRay said: Didn't work and worst, the launcher is now not launching at all due to "general error". Verifying stellaris installation now in steam.
Ok after uninstalling the (manualy as on the reddit thread) installed launcher, then reinstalling it when starting the stellaris game, it is back, but still "you seem not connected". In English it uses other words, but the idea is the same.

The only "consequence" seems to be: not having the news in the launcher so... isn't the error on your part, paradox??
It's possible, but why then would it not affect every user running the launcher?

What firewalls do you have in use? In Windows Defender make sure stellaris.exe , and Paradox Launcher.exe are allowed through both the Public and Private domains.  
about 1 year ago - AndrewT - Direct link
Towboat421 said: I tried this of my own volition no dice chief, it was very sudden too just sort of turned it on one day and it was there.
Does it only affect Stellaris for you too?  
about 1 year ago - AndrewT - Direct link
AngelRay said: Windows defender and yes stellaris is in the list. The paradox launcher doesn't appear anywhere in the list and I don't know where it is installed since I do not have this in my steam library. (I own all my Paradox game on steam...)
C:/users//AppData/Local/Programs/Paradox Interactive/laincher-v2.2020.11/Paradox launcher.exe  
about 1 year ago - AndrewT - Direct link
I didn't expect reinstalling the game to affect this launcher problem.

I'll post in the launcher support thread, see if the developers have any ideas for us.  
about 1 year ago - AndrewT - Direct link
Spieler Null said: - Launcher Version 2020.3 (not 2020.11)
Please try this:

- exit the Steam app entirely
- uninstall Paradox Launcher v2 from the Windows "Apps and features" utility, if still present.

Delete the following folders if still present:

- C:/users//AppData/Local/Programs/Paradox Interactive/
- C:/users//AppData/Local/Paradox Interactive/
- C:/users//AppData/Roaming/Paradox Interactive/launcher-v2/
To see the AppData folder you'll need to enable View Hidden Items in File Explorer.

- run steam.exe as the Windows Admin user

- run the game from the PLAY button in Steam

IF that doesn't help, in this folder are some .log files:
C:/users//AppData/Local/Paradox Interactive/launcher-v2/
Please attach them here.  
15 days ago - AndrewT - Direct link
jzbrochu said: I have the same problem and have tried the same. Did not work. These are my .log files.
In future please make a new thread instead of reopening an old one, thanks. Things have changed a lot in the last year.

You seem to be on the curren tlauncher 2021.8.1 , is that right?

Are you logged into that launcher okay?

Aside from the news error can you run and play the game okay?  
14 days ago - AndrewT - Direct link
What happens if you run stellaris.exe directly, which bypasses the launcher?