Original Post — Direct link

Asking this on behalf of someone else. The game used to work fine, then he started getting the "Can not connect to Uplay" error randomly (first once in a while and eventually several times a day) so he stopped playing several months ago. Now he wanted to try again and is facing new errors (0x00002EE2 and 0x0000274C). Problem is we can't find much info on these codes anywhere. The only thing I could find was https://discussions.ubisoft.com/topic/123434/error-when-trying-to-create-a-campaign?lang=en-US which is not related to launching / connecting to the game. He is playing directly through Ubisoft Connect, not Steam or Epic involved.

Edit: Some additional info about what we've tried so far; firewall and antivirus off, allowing ports 2350-2459 through firewall, verifying game files, reinstalling the game and finally I installed the game too to see if it was our ISP or router and was able to connect without any issues. So it must be something on his PC that is causing the issue, we just have clue what it is because he can browse the internet and has no issues playing other games online including other Ubisoft games.

25 days ago - Ubi-TheBerry - Direct link

Hey @jordeee9 ,

If you haven't done so already, could you please make sure you give all the steps in this connectivity guide a try?

@LaeLenna - thank you for sharing the steps you've tried so far.

We'll need to look into this directly with your friend to be able to best support them.

Could you please have them send us a message directly via our Support Site, Facebook or Twitter and attach their DxDiag and MSinfo system files?

We'll take a further look into this there.

Thank you!