9 months ago - EA_Illium - Direct link
@KillerSpectre42 Which platform are you playing on? Illium.png

*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.
9 months ago - EA_Illium - Direct link

Hi @KillerSpectre42 Can you try going through the following steps and check if you continue running into connection issues?

 

  • Connection and Advance Connection Guides 
  • Change DNS settings (You can use the public google DNS primary: 8.8.8.8, secondary: 8.8.4.4, unless there is a different DNS you would rather use)  
  • Change power saving options 
  • Close other running games or apps, (for Series X|S also close others running in quick resume) 
  • Remove any connected device, additional USB's from the console and restart 
  • Check for updates 
  • Persistent Storage 
    • Go to settings > Select Device & Connections > Then Blue-Ray 
    • Select Persistent Storage > Clear Persistent Storage 
  • Alternate Mac: 
    • Go to settings > Select General  > Then Network settings 
    • Go to advanced settings > Alternate Mac address > Select clear 
    • Select restart 

 

 

Illium.png

*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.