Original Post — Direct link

I claimed "The Way of Berserker" mission via Ubisoft Connect rewards, but it does not show up in my quests/map.
I have finished everything including DLCs, yet I have no letters in my settlement in order start this mission.

I have tried verifying game files but that didn't help either. I'm on PC.
I have also tried disconnecting/connecting from Internet but didn't work.

Also, since I claimed this mission from rewards, I get the following error on each start up.
And now it takes a very long time on "Checking Add-Ons" message and loading the game.

Please, help. Thank You.



6 days ago - Ubi-Froggard - Direct link

Hey @WrecK3rr

I'm sorry to hear this isn't showing for you and is now causing it to take longer to get on the game. When you tried disconnecting from the internet and reconnecting, did you try doing this whilst in-game already? If not, please try this.


5 days ago - Ubi-MrM - Direct link

@WrecK3rr Understood, thank you for the details !

In addition to these steps, can you also let us know if the ones shared by @azullFR in this thread helped ? (many thanks for sharing it in this thread by the way !)

This will help our investigation, in order to isolate the Issue.

Don't hesitate to let us know if you'd like to share additional details, or if you have any questions !






Recent Assassin's Creed: Valhalla Posts

about 23 hours ago - Ubi-MrM