Original Post — Direct link

Game won't save. At all. When it attempts to do so, I get an error message claiming that it can't connect to the cloud. I might have only lost one hour of progress, except that I tried to manually save, and now my save game is listed as corrupted.

This happened during the mission when you're riding on horseback with Randvi.

I have heard from other people that sleeping in your bed or starting a feast will temporarily fix the bug, but neither worked for me. Left with no alternative, I left my game. Now on startup, I get a wonderful message informing me that I need a product activation code, a code, mind you, for a game I had previously brought three years ago with all the dlc. Btw, it looks like I won't be able to play the Ragnarok dlc either. Thanks ubi.

21 days ago - Ubi-Keo - Direct link

Hi @h8uoobi I'm sorry to hear that you have experienced issues saving your game and that you are also being prompted to enter an activation code, that is strange.

To confirm are you unable to access the game at all now due to the prompt for the activation code?