Original Post — Direct link

Playing on UAE servers most of the time it rubber bands in rank and unrank but quick play is ok. Why is this happening and what is the fix ?

It is really annoying.

about 2 months ago - Ubi-TheBerry - Direct link

Hey @omiyeePUCKu,

As this sounds like it's relating to Rainbow Six: Siege rather than Extraction, I've moved your thread to the right forum.

As for the rubber banding, do you notice that your ping or FPS changes drastically at these times?

To allow us to determine if this is in relation to your hardware or connection.

Thank you!

about 2 months ago - Ubi-Milky - Direct link

Hello @omiyeePUCKu thanks for getting back to us on the UAE servers.

We do have an open investigation into the UAE servers, but we haven't had any reports of UAE server issues since July.

Could you please run through each of the steps listed in this guide to see if it can help resolve your issue, or rule out a few possible causes of where this rubber band may be coming from > https://www.ubisoft.com/en-gb/help/article/000094617

Should these steps not resolve this issue for you,  please contact us via our Help website, for further help > https://www.ubisoft.com/en-gb/help/contact

We may need your dxdiag and port forwarding information to help diagnose this issue further!


about 1 month ago - Ubi-Ciel - Direct link

Hey there @omiyeePUCKu !

To share your DxDiag and port forwarding files with us, you'll need to reach out to our colleagues over at the Ubisoft Support - who will be able to investigate those files and locate the source of the issue you're experiencing. Here are the links you can use to contact them privately on whichever platform you prefer 😊

- Ubisoft Support website: https://support.ubisoft.com/Cases/new
- Twitter: https://twitter.com/UbisoftSupport
- Facebook: https://www.facebook.com/UbisoftSupport/