Original Post — Direct link

When connecting from AUS to the SEA data centres, I would usually be getting around 90 ms, but about a month ago that suddenly shot up to a constant 150 ms. Keep in mind I am only having this issue when trying to connect to the SEA data centres, others work as it did before.

I have tried using both wired and wireless connection, flushed my DNS and such.

15 days ago - Ubi-TheBerry - Direct link

Hey @Xav___ ,

Thank you for getting in touch.

Have you yet tried manually changing your data centre to australiaeast to see if there's any improvements there?

We have a guide on updating your data centre here.

Let us know if this helps at all!

10 days ago - Ubi-Milky - Direct link

Hello @Xav___ thank you for getting back to us.

We have not received any other recent reports of high ping on the SEA servers, or any changes that would have caused your normal 90ms to jump to 150ms, but this is something we can monitor for reports from our SEA datacentre players going forward.

The only thing we can suggest you try, is to run through all of our connectivity troubleshooting steps, to see if this may help improve your connection to this particular SEA datacentre going forward >>

Connect PC connectivity guide > https://ubi.li/YPwnl
Steam PC guide (if you have purchased for this platform) > https://support.steampowered.com/kb_article.php?ref=1456-EUDN-2493: (https://support.steampowered.com/kb_article.php?ref=1456-EUDN-2493)