12 days ago - MrFreake_PDX - Direct link
If your issue persists after the master fixes thread, you can go to support.paradoxplaza.com and open a ticket, and Customer Support will likely be able to help you out with this!
12 days ago - AndrewT - Direct link
Olexnev said: Hello. I really like Stellaris. Great game!

But I can't play anymore. All time after 5-10 minutes game completely freeze my PC. Music continue to play but PC do not respond anymore. Only hard reset remaining in this situation.

I tried every solution what I found: fullscreen, windowed mode, administrator mode, reininstall the game, delete all folders, reinstall luncher. Problem still exist.

I have all the DLC. No mods installed.

My PC is powerful enough. AMD Ryzen 9 3900XT, Radeon 6900 XT, 64 GB Ram. Fresh Windows 10 with all updates.

Only Stellaris have this problem. Other games work perfectly.

Can you help me please?
Sounds like it hasn't always done this, is that right? Can you pivk any change or update that seemed to trigger the first occurrence?


Right click on stellaris.exe , properties, compatibility. Tick "disable fullScreen optimisations" untick every other box in that dialog, Apply and exit.
Then in the launcher Game Settings menu, select fullScreen display mode, Vsync off, refresh rate 60.


If that doesn't help:
DXDIAG is a program you run from the Windows search box on the task bar. After running it will open a window and start collecting info with a progress bar in the lower-left corner. When it completes click the 'save all information' button and save it to a file then attach that file here.

Please attach here your Documents/Paradox Interactive/Stellaris/settings.txt and pdx_settings.txt .
From your Documents/Paradox Interactive/Stellaris/logs/ folder, attach here system.log , error.log .


AND Please report the temperatures of your CPU and video (GPU)
1/ before starting the game up and
2/ after say 10 minutes' play, or just before it happens if you can
If your PC's vendor has given you no way of reading temperatures, install
SPEEDFAN http://www.almico.com/sfdownload.php  
12 days ago - AndrewT - Direct link
tulicreme said: Same issue.
Uninstalled the game, removed all %APPDATA% related content and user configs under "My Documents", reinstalled and same happens.

Exiting Steam does end up killing the process, but it's hardly a solution.
If you can exit Steam yours is a different problem than the OP's, as they have to hit the hardware reset button.

Please make your own thread, with full system details and problem history. Thanks.
 
11 days ago - AndrewT - Direct link
Olexnev said: My monitor is 240 Hz. I can try 60 Hz but it really not the best solution.
Can you at least try it, as a test?

Olexnev said: Temperatures seems fine.
Can we get exact numbers please?


From your Documents/Paradox Interactive/Stellaris/logs/ folder, attach here system.log , error.log