Original Post — Direct link
I've been experiencing this bug with all maps I created. When removing one item with the delete tool, some other items all over the map are also removed, as if they are linked in some way. This happens when removing some items (not all of them), and the removed items are always the same ones. This is specially annoying when you have hundreds of items and half of them are deleted when you want to delete just one of them.

Here you have 2 screenshots that reproduce the bug in a simple way:

3 months ago - Ubi-Milky - Direct link
Hello agsmtc, thank you for posting in the forums about this.

Have you been able to try u.B.m's advice when deleting items by using the shift key and did this work for you?
2 months ago - Ubi-Raziel - Direct link
Thank you all for getting back to us!

Our devs have been made aware of this issue however they've not been able to reproduce it just yet.

I'd like to request some information, which should help us -

- Are you able to provide a video of this happening?
- Which blocks were affected by the issue?
- Are those blocks custom?

Thank you!
2 months ago - Ubi-WheelyDuck - Direct link
Originally Posted by Rxelux
- Yes: https://youtu.be/zv_yimyZ1vQ
- Items are affected by the issue (upon saving and reloading a map)
- Affected Items are custom (cf video) and official (cf fist post)

partial workaround: checking the "Not On Object" flag for items seem to prevent the issue (if both are flagged as such, if not the one without the flag will still get deleted).
This make custom items more difficult to place.
This does not fix the issue for official items.

(Possibly related issue: items placed before block get deleted if block is then removed (even if flagged as "Not On Object") https://youtu.be/wleLQO0OIIs )
Thank you for providing this video and those details.

Can I check whether this happens with all blocks and items or just what you have showed?

I ask this to be as thorough as possible.

Many thanks
about 2 months ago - Ubi-Milky - Direct link
Hey Rxelux, thanks for getting back to us with that information. I have passed those details and your video onto the team to view for our investigation. We hope we can update you soon with good news!
about 2 months ago - Ubi-Milky - Direct link
Hey Trackmaniadude and SparklingW, thanks for adding your experience, this should prove helpful to the team I believe and have added it to our report on erasing items in the map editor.

The team also wanted to know if this only affects custom blocks in the Editor mode or all blocks so I will let them know. Thanks again.
about 1 month ago - Ubi-Milky - Direct link
Thanks for clarifying SparklingW and sorry for the delay getting back to you. I will make sure this information is added to the investigation, thanks again for your input and bringing this to our attention.





Links in this thread

TMN ItemVanish2
Items placed before block get deleted if block is then removed (even if flagged as "Not On Object")


TMN ItemVanish
Item Vanish bug reproduce steps


TM error 2 - Image on Pasteboard
Simple and lightning fast image sharing. Upload clipboard images with Copy & Paste and image files with Drag & Drop


TM editor error - Image on Pasteboard
Simple and lightning fast image sharing. Upload clipboard images with Copy & Paste and image files with Drag & Drop


devtrackers.gg