Original Post — Direct link

Ever since the Oskoreia Festival launched I have encountered a few more crashes during gameplay on my Xbox Series X. However, as of today, I cannot seem to get an save file to load. None of them show corrupt, but when I select Continue or Load Save from the menu, the game file selected appears to load, then the screen goes completely black, and I am returned to the Xbox home page with no error message. I have seen recent reports of a few games on Xbox Series X crashing and there appears to be a "system-level problem on Microsoft's side" but Assassin's Creed Valhalla is not on the list of games experiencing the problem but I do realize that could be due to lack of reports. Through my entire lengthy time of playing Valhalla I have rarely experienced any crashes. This is the AutosaveCLOUD file that was the most recent:

">


Here's a recording of what happens:
">

But as of today I cannot even get a game file to load without crashing and return to the Xbox home page. I've already hard rebooted the console, uninstalled and reinstalled the entire AC Valhalla game files, and tried some other minor troubleshooting but at this point I am unable to play Assassin's Creed Valhalla. Please advise and/or confirm with Microsoft if Assassin's Creed Valhalla is also affected by the system-level hardware problem being encountered. Also please let me know if you need any other information. Thank you,

17 days ago - UbiMint - Direct link

Hi there @TheeElf!

Thank you for the in-depth description of the issue you're experiencing, as well as the image and clip! I'm sorry to hear you're experiencing this crash issue when you try to load your game. Just to check, were these the steps you tried when troubleshooting? Also, are you able to create a new save file by any chance? If so, please let me know if the new one loads or has the same behavior as your other saves.






Recent Assassin's Creed: Valhalla Posts