Original Post — Direct link

I got this through Epic; played for awhile (1d 14h per Epic's data), then uninstalled it.
This was a few months back.

Now I went back and re-installed it, ran first time and Ubisoft downloaded a large update to the game, then displayed "Play",
but when I click Play, it opens the AC:V logo screen, initializes, then just sits there with a spinning circle, essentially forever (actually, I only left it spinning for 20 minutes, but that should be sufficient).

I tried the following fixes with no effect:

  1. put Ubisoft offline
  2. ran Verify Files; all verified fine.


Is there a fix for this??

My system:
Windows 10 Pro 64-bit, all drivers/files updated
NVidia GTX 1070 Ti, current drivers
CPU: Ryzen 7 3700X
Install disk: Samsung 980 Pro, PCIe4 NVMe interface, plenty of free disk available
32GB DRAM, 18GB free

12 days ago - Ubi-Milky - Direct link

Hello @derelllicht thanks for getting in touch with us about this disappearing play button.

Thanks for letting us know what you have tried so far, I have three suggestions I would like you to try, which I think may resolve this for you >

1.Use the locate game tool in our launcher, to reassociate all of the game files so Ubisoft Connect can find them. To do this, follow this guide, then restart the launcher >
https://www.ubisoft.com/help?article=000065557

2.Delete Ubisoft Connects cache folder, after first backing it up on your desktop. Please see this guide for how to do this >
https://www.ubisoft.com/help?article=000061966

3.Should the above step not solve the issue after restarting the launcher, please reinstall Ubisoft Connect and completely reinstall it