Original Post — Direct link

I have come to a bug inside the Boudicca Tomb ( East Anglia region ).
I have placed one orb succesfully, but when taking back the 2nd one to place onto the other floor pedestal, there is no interaction prompt.
Im playing on PS5 so this should give me the triangle interaction prompt but its not doing it.
I have tried reloading my save, restarting the game but nothing seems to help. Ive also tried fast travelling to another region and returning but all to no avail.
I also do not have a save game from right where i started the tomb, so now this tomb seems incompletable.
Has anyone found a workaround for this ?

about 2 months ago - Ubi-Oxavo - Direct link

Hello @EvilHannie! Thank you for contacting Ubisoft support and I apologize for my delayed response.

You recently informed us that you are unable to proceed inside the Boudicca Tomb as there is no prompt to pick it up.
The development team has been made aware of this issue and they are currently investigating it. Once additional information becomes available, this will be shared in the News & Announcements forum, so please check here for the most up-to-date information.

Thanks and don't hesitate to get back to us if you need additional help!






Recent Assassin's Creed: Valhalla Posts