Original Post — Direct link
Attempted to launch Valhalla, splash screen appeared, and there it sits, not even loading as far as the menu. Task manager says ACValhalla_Plus.exe is using 0.00 CPU while taking up 633.5 MB of RAM.

My system is more than capable of supporting it:
Ryzen 7 18800X
32GB RAM
Radeon RX 580
8192MB VRAM
16TB HD
Windows 10 Pro on a 1TB SSD
13 days ago - Ubi-Woofer - Direct link
Hey Yukiyoroi and HawkSE, thanks for posting about the issues you're experiencing with launching Assassin's Creed Valhalla. I'm sorry to hear that these crashes are occurring on the splash screen.

If you have the game installed on a drive formatted as a Microsoft Storage Space Device (MSSD), please be advised that these are not compatible with the game and will cause the game to crash. You will need to install the drive on a conventional storage device in order for it to work.

If you do not have the game on a MSSD, please attempt our basic PC troubleshooting, and if issues continue, post over on our new Assassin's Creed Valhalla forums here for further troubleshooting suggestions and support. These forums are no longer in use and will not be updated going forward. You have both mentioned opening support cases - my colleagues will be in touch as soon as possible there to assist you as well. Thank you!





Links in this thread

Player Support
Use this forum for any technical or connectivity issues, bug reporting and gameplay questions.


Troubleshooting technical issues on PC
What can I do if I experience technical difficulties while playing on PC?


devtrackers.gg